どくたーぺっぱーちぇりお

08<< 123456789101112131415161718192021222324252627282930 >>10

スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

Ruby on Railsをアップデートするには

以前、gem installしていたrailsだが、新しいバージョンが2日ほど前にリリースされていたようだ。
ソースはこの通り。
Rails 3.1.1 has been released!
http://weblog.rubyonrails.org/2011/10/7/ann-rails-3-1-1

新しいバージョンがリリースされるのは嬉しいが、今までアップデートしたことが無かったぜ。
アップデートの方法は、なんとなく予測はつくが・・・

~$ rails -v
Rails 3.1.0
~$ sudo gem install rails
>[sudo] password for user:
(中略)
Fetching: rails-3.1.1.gem (100%)
(中略)
Successfully installed rails-3.1.1
(中略)
Installing RDoc documentation for rails-3.1.1...

そういえば、ドキュメントとか、まだ読んだことが無いや。未熟者ですね。
しかし、特に労せずともアップデートされました。
他にも、activerecord-3.1.1, actionpack-3.1.1なども一緒に入ったよ。

~$ rails -v
Rails 3.1.1

ねんのためにバージョンを確認して、完了。
関連記事

COMMENT▼

続き 前のバージョンを削除してよければ削除しておくこと。

実は、そのままでは、前のバージョンと両方インストールされた状態らしい。
そして確認するのも、前のバージョンを削除するのも、そう難しい事ではなかった。

gem uninstall rails

>Select gem to uninstall:
> 1. rails-3.1.0
> 2. rails-3.1.1
> 3. All versions
1
>Successfully uninstalled rails-3.1.0

更に続き 他のパッケージも確認して、不要なものは削除する

gem listして、出てきた一覧から不要なものはgem uninstallで削除する。

gem list

*** LOCAL GEMS ***

actionmailer (3.1.1)
actionpack (3.1.1)
activemodel (3.1.1)
・・・

gem uninstall activerecord

Select gem to uninstall:
1. activerecord-3.1.0
2. activerecord-3.1.1
3. All versions
> 1
Successfully uninstalled activerecord-3.1.0

コメントの投稿

管理者にだけ表示を許可する

TRACKBACK▼

http://doctorpeppercheerio.blog.fc2.com/tb.php/57-12383315

この記事にトラックバックする(FC2ブログユーザー)

 | ホーム | 

プロフィール

だーくちぇりー

Author:だーくちぇりー
名前:darkcherry(だーくちぇりー)
特技:器用貧乏
職業:まぜまぜ屋

QRコード

QR

検索フォーム

    上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。